Get in touch
Back
Degraded

Slow email verification

Started 22 Apr at 05:10pm HDT, resolved 23 Apr at 02:12am HDT.

Frontend app
Resolved

Services appear to be back to normal. We needed to revert back to our old queuing method. We may experience interruptions as we try to bring the new queuing back online, and will provide future status updates if that is the case. We will do our best to avoid any interruption.

Posted 23 Apr at 02:12am HDT.
Updated

The backlog has been cleared and email verification has resumed back to normal. We will continue to monitor the situation to ensure systems have fully recovered.

Posted 23 Apr at 02:09am HDT.
Updated

We've been able to resume email verification and are currently working through the backlog. This will take some time as our database is also degraded due to the large backlog. Thank you for your continued patience as we continue to work through the queue.

Posted 22 Apr at 11:26pm HDT.
Created

We're currently experiencing severe degradation due to blocked queues. Email verification is very slow. We're working hard to resolve this asap. Thanks for your understanding and patience as we work to resolve the issue.

Posted 22 Apr at 05:10pm HDT.