Get in touch
Back
Degraded

Slow email verification

Started 16 Nov at 05:46am HST, resolved 16 Nov at 08:22am HST.

Frontend app
Resolved

Service is back to normal. We will continue to monitor the situation. Thanks for your patience as we worked to restore service back to normal.

Posted 16 Nov at 08:22am HST.
Created

We're currently experiencing many response timeouts and are investigating. Email verification is slower than usual. Thanks for your patience as we work to resolve the issue.

Posted 16 Nov at 05:46am HST.